CVE-2015-5271 — tripleo-heat-templates
HIGHCVE-2015-5271 is a high-severity (CVSS 7.5) Information Exposure vulnerability in tripleo-heat-templates. A fix is available for tripleo-heat-templates — see the affected versions and patch details below.
TripleO Heat templates might allow remote attackers to obtain sensitive information from private containers
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
tripleo-heat-templatesReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
The TripleO Heat templates (tripleo-heat-templates) do not properly order the Identity Service (keystone) before the OpenStack Object Storage (Swift) staticweb middleware in the swiftproxy pipeline when the staticweb middleware is enabled, which might allow remote attackers to obtain sensitive information from private containers via unspecified vectors.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | tripleo-heat-templates | all versions | 0.8.7pip install --upgrade 'tripleo-heat-templates==0.8.7' |
Affected Products
tripleo heat templatesopenstackopenstackredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tripleo-heat-templates, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tripleo-heat-templates to 0.8.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-5271 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux OpenStack Platform director 7.0 for RHEL 7 | ahc-tools-0:0.1.1-6.el7ost | RHSA-2015:1862 |
Frequently Asked Questions
Is CVE-2015-5271 in your dependencies?
Find it across PyPI, including transitive dependencies.