CVE-2015-5161 — zendframework
Fix: zendframework/ZendXml@79f478fCVE-2015-5161 is a security vulnerability in zendframework/zendframework. 7 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for zendframework/zendframework — see the affected versions and patch details below.
ZendXml and Zend Framework contain XXE and XEE Vulnerabilities
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
zendframework/zendframework🐘zendframework/zendframework🐘zendframework/zendframework1🐘zendframework/zendxml🐘zendframework/zendframeworkReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The Zend_Xml_Security::scan in ZendXml before 1.0.1 and Zend Framework before 1.12.14, 2.x before 2.4.6, and 2.5.x before 2.5.2, when running under PHP-FPM in a threaded environment, allows remote attackers to bypass security checks and conduct XML external entity (XXE) and XML entity expansion (XEE) attacks via multibyte encoded characters.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | zendframework/zendframework | ≥ 2.0.0&&< 2.4.6 | 2.4.6composer require zendframework/zendframework:^2.4.6 |
| 🐘Packagist | zendframework/zendframework | ≥ 2.5.0&&< 2.5.2 | 2.5.2composer require zendframework/zendframework:^2.5.2 |
| 🐘Packagist | zendframework/zendframework1 | ≥ 1.12.0&&< 1.12.14 | 1.12.14composer require zendframework/zendframework1:^1.12.14 |
| 🐘Packagist | zendframework/zendxml | ≥ 1.0.0&&< 1.0.1 | 1.0.1composer require zendframework/zendxml:^1.0.1 |
| 🐘Packagist | zendframework/zendframework | ≥ 1.12.0&&< 1.12.14 | 1.12.14composer require zendframework/zendframework:^1.12.14 |
Affected Products
zend frameworkzendResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
eBay Magento 1.9.2.1 - PHP FPM XML eXternal Entity Injection
by Dawid Golunski · Oct 30, 2015
Zend Framework 2.4.2 - PHP FPM XML eXternal Entity Injection
by Dawid Golunski · Aug 13, 2015
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zendframework/zendframework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update zendframework/zendframework to 2.4.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-5161 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2015-5161 in your dependencies?
Find it across Packagist, including transitive dependencies.