NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2015-5144 — django

HIGHFix: django/django@1ba1cdc

CVE-2015-5144 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in django. A fix is available for django — see the affected versions and patch details below.

Django Vulnerable to HTTP Response Splitting Attack

Also known asGHSA-q5qw-4364-5hhmPYSEC-2015-10
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.2%probability of exploitation in next 30 days
Lower Risk-0.50%
Lower risk than most CVEs88th percentile — riskier than 88% of all scored CVEsHighest risk
0.84%2.00%3.16%4.32%2.2%3.2%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍django🐍django🐍django

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Django before 1.4.21, 1.5.x through 1.6.x, 1.7.x before 1.7.9, and 1.8.x before 1.8.3 uses an incorrect regular expression, which allows remote attackers to inject arbitrary headers and conduct HTTP response splitting attacks via a newline character in an (1) email message to the EmailValidator, a (2) URL to the URLValidator, or unspecified vectors to the (3) validate_ipv4_address or (4) validate_slug validator.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIdjangoall versions1.4.21pip install --upgrade 'django==1.4.21'
🐍PyPIdjango≥ 1.5&&< 1.7.91.7.9pip install --upgrade 'django==1.7.9'
🐍PyPIdjango≥ 1.8a1&&< 1.8.31.8.3pip install --upgrade 'django==1.8.3'

Affected Products

4 products · 58 configurations
OS
ubuntu linuxcanonical
4 versions
12.0414.0415.0415.10
OS
debian linuxdebian
2 versions
7.08.0
Application
djangodjangoproject
≤ 1.4.20
38 versions
1.51.5.11.5.21.5.31.5.41.5.51.5.61.5.71.5.81.5.91.5.101.5.11
OS
solarisoracle
1 version
11.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update django to 1.4.21 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-5144 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Django before 1.4.21, 1.5.x through 1.6.x, 1.7.x before 1.7.9, and 1.8.x before 1.8.3 uses an incorrect regular expression, which allows remote attackers to inject arbitrary headers and conduct HTTP response splitting attacks via a newline character in an (1) email message to the EmailValidator, a (2) URL to the URLValidator, or unspecified vectors to the (3) validate_ipv4_address or (4) validate_slug validator.
O3 Security · Impact-Aware SCA

Is CVE-2015-5144 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2015-5144: django — Fixed in 1.4.21