NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2015-4082 — attic

MEDIUMFix: jborg/attic@78f9ad1

CVE-2015-4082 is a medium-severity (CVSS 6.5) CWE-264 vulnerability in attic. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for attic — see the affected versions and patch details below.

attic has improper verification of unencrypted backups

Also known asPYSEC-2017-6
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs85th percentile — riskier than 85% of all scored CVEsHighest risk
0.36%1.23%2.11%2.99%0.9%2.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍attic

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

attic before 0.15 does not confirm unencrypted backups with the user, which allows remote attackers with read and write privileges for the encrypted repository to obtain potentially sensitive information by changing the manifest type byte of the repository to "unencrypted / without key file".

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIatticall versions0.15pip install --upgrade 'attic==0.15'

Affected Products

1 product · 1 configurations
Application
atticattic_project
≤ 0.14
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for attic, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update attic to 0.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-4082 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

attic before 0.15 does not confirm unencrypted backups with the user, which allows remote attackers with read and write privileges for the encrypted repository to obtain potentially sensitive information by changing the manifest type byte of the repository to "unencrypted / without key file".
O3 Security · Impact-Aware SCA

Is CVE-2015-4082 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2015-4082: attic Info Disclosure — Fixed in 0.15