CVE-2015-4053 — ceph-deploy
Fix: ceph/ceph-deploy#300CVE-2015-4053 is a Information Exposure vulnerability in ceph-deploy. A fix is available for ceph-deploy — see the affected versions and patch details below.
ceph-deploy uses world-readable permissions on client.admin key
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
ceph-deployReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
The admin command in ceph-deploy before 1.5.25 uses world-readable permissions for /etc/ceph/ceph.client.admin.keyring, which allows local users to obtain sensitive information by reading the file.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | ceph-deploy | all versions | 1.5.25pip install --upgrade 'ceph-deploy==1.5.25' |
Affected Products
ceph-deploycephDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ceph-deploy, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ceph-deploy to 1.5.25 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-4053 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Ceph Storage 1.2 for CentOS | see advisory | RHSA-2015:1631 |
| Red Hat Ceph Storage 1.2 for RHEL 6 | ceph-deploy-0:1.5.22-0.4.rc1.el6cp | RHSA-2015:1092 |
| Red Hat Ceph Storage 1.2 for Ubuntu | see advisory | RHSA-2015:1579 |
Frequently Asked Questions
Is CVE-2015-4053 in your dependencies?
Find it across PyPI, including transitive dependencies.