NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2015-3337 — elasticsearch

CVE-2015-3337 is a Path Traversal vulnerability in org.elasticsearch:elasticsearch. 5 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.elasticsearch:elasticsearch — see the affected versions and patch details below.

Improper Limitation of a Pathname to a Restricted Directory in Elasticsearch

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
5 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
33.2%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs98th percentile — riskier than 98% of all scored CVEsHighest risk
15.5%43.7%71.8%100.0%91.1%33.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
☕org.elasticsearch:elasticsearch☕org.elasticsearch:elasticsearch

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Directory traversal vulnerability in Elasticsearch before 1.4.5 and 1.5.x before 1.5.2, when a site plugin is enabled, allows remote attackers to read arbitrary files via unspecified vectors.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.elasticsearch:elasticsearchall versions1.4.5org.elasticsearch:elasticsearch:1.4.5
☕Mavenorg.elasticsearch:elasticsearch≥ 1.5.0&&< 1.5.21.5.2org.elasticsearch:elasticsearch:1.5.2

Affected Products

1 product · 3 configurations
Application
elasticsearchelasticsearch
≤ 1.4.4
2 versions
1.5.01.5.1
Exploits & PoCs
5

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-37054webappsphp

ElasticSearch < 1.4.5 / < 1.5.2 - Directory Traversal

by pandujar · May 18, 2015

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.elasticsearch:elasticsearch, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.elasticsearch:elasticsearch to 1.4.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-3337 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

How to detect CVE-2015-3337

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2015-3337 -u https://target
Template
Elasticsearch - Local File Inclusion
Severity
medium
Impact
An attacker can exploit this vulnerability to read sensitive files on the server.
Remediation
Upgrade to a patched version of Elasticsearch or apply the necessary security patches.

Template by ProjectDiscovery nuclei-templates (pdteam), MIT licensed. View the full template. Scan only systems you are authorised to test.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow

This issue affects the versions of elasticsearch as shipped with Red Hat Satellite 6.x and Subscription Asset Manager 1.x. Red Hat Product Security has rated this issue as having Low security impact. A future update may address this issue. For additional information, refer to the Issue Severity Classification:…

Workaround published by Red Hat
Users that do not want to upgrade can address the vulnerability in several ways, but these options will break any site plugin: * Set http.disable_sites to true in the elasticsearch.yml config file on any node with a site plugin, and restart the Elasticsearch node. * Use a firewall or proxy to block HTTP requests to /_plugin. * Uninstall all site plugins from all Elasticsearch nodes. For Satellite 6.x and Sam 1.x you can simply firewall elasticsearch to trusted users only (e.g. root, katello, foreman). For instructions on this please…
Source: Red Hat security advisory for CVE-2015-3337 (CC BY 4.0)

Frequently Asked Questions

Directory traversal vulnerability in Elasticsearch before 1.4.5 and 1.5.x before 1.5.2, when a site plugin is enabled, allows remote attackers to read arbitrary files via unspecified vectors.
O3 Security · Impact-Aware SCA

Is CVE-2015-3337 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2015-3337: elasticsearch — Fixed in 1.4.5