NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2015-3296 — nodebb

MEDIUMFix: NodeBB/nodebb-plugin-markdown@ab7f268

CVE-2015-3296 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in nodebb. A fix is available for nodebb — see the affected versions and patch details below.

NodeBB Cross-site Scripting Vulnerability in Markdown Processing

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs70th percentile — riskier than 70% of all scored CVEsHighest risk
0.00%0.59%1.18%1.76%0.3%1.3%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

0other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
nodebbnpm
224downloads / week
nodebb-plugin-markdownnpm
5Kdownloads / week

Description

Multiple cross-site scripting (XSS) vulnerabilities in NodeBB before 0.7 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) javascript: or (2) data: URLs.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmnodebball versions0.70npm install nodebb@0.70
📦npmnodebb-plugin-markdownall versions5.1.1npm install nodebb-plugin-markdown@5.1.1

Affected Products

1 product · 1 configurations
Application
nodebbnodebb
≤ 0.6.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nodebb, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update nodebb to 0.70 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-3296 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Multiple cross-site scripting (XSS) vulnerabilities in NodeBB before 0.7 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) javascript: or (2) data: URLs.
O3 Security · Impact-Aware SCA

Is CVE-2015-3296 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2015-3296: nodebb XSS — Fixed in 0.70