NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2015-3272 — moodle

HIGHFix: moodle/moodle@5673aae

CVE-2015-3272 is a high-severity (CVSS 7.4) vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Moodle open redirect vulnerability

Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs79th percentile — riskier than 79% of all scored CVEsHighest risk
0.00%0.78%1.57%2.35%0.3%1.8%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Open redirect vulnerability in the clean_param function in lib/moodlelib.php in Moodle through 2.6.11, 2.7.x before 2.7.9, 2.8.x before 2.8.7, and 2.9.x before 2.9.1 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via vectors involving an HTTP Referer header that has a substring match with a local URL.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 2.7.0&&< 2.7.92.7.9composer require moodle/moodle:^2.7.9
🐘Packagistmoodle/moodle≥ 2.8.0&&< 2.8.72.8.7composer require moodle/moodle:^2.8.7
🐘Packagistmoodle/moodle≥ 2.9.0&&< 2.9.12.9.1composer require moodle/moodle:^2.9.1

Affected Products

1 product · 28 configurations
Application
moodlemoodle
28 versions
2.6.02.6.12.6.22.6.32.6.42.6.52.6.62.6.72.6.82.6.92.6.102.7.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 2.7.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-3272 is resolved across your whole dependency graph.

  3. Workarounds

    Stop reflecting attacker-controlled destinations: resolve every redirect target against an allowlist of paths or hosts you own, prefer a server-side key over a full URL in the request, and reject absolute URLs entirely where the flow only ever needs a relative one.

Frequently Asked Questions

Open redirect vulnerability in the clean_param function in lib/moodlelib.php in Moodle through 2.6.11, 2.7.x before 2.7.9, 2.8.x before 2.8.7, and 2.9.x before 2.9.1 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via vectors involving an HTTP Referer header that has a substring match with a local URL.
O3 Security · Impact-Aware SCA

Is CVE-2015-3272 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2015-3272: moodle Open Redirect — Fixed in 2.7.9