NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2015-3250 — api-ldap-model

HIGH

CVE-2015-3250 is a high-severity (CVSS 7.5) Information Exposure vulnerability in org.apache.directory.api:api-ldap-model. A fix is available for org.apache.directory.api:api-ldap-model — see the affected versions and patch details below.

Exposure of Sensitive Information to an Unauthorized Actor in Apache Directory LDAP API

Also known asGHSA-cx3q-cv6w-mx4h
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
5.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
1.12%2.76%4.40%6.04%2.0%5.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.directory.api:api-ldap-model

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache Directory LDAP API before 1.0.0-M31 allows attackers to conduct timing attacks via unspecified vectors.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.directory.api:api-ldap-modelall versions1.0.0-M31org.apache.directory.api:api-ldap-model:1.0.0-M31

Affected Products

1 product · 1 configurations
Application
directory ldap apiapache
≤ 1.0.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.directory.api:api-ldap-model, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.directory.api:api-ldap-model to 1.0.0-M31 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-3250 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

Apache Directory LDAP API before 1.0.0-M31 allows attackers to conduct timing attacks via unspecified vectors.
O3 Security · Impact-Aware SCA

Is CVE-2015-3250 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2015-3250: api-ldap-model — Fixed in 1.0.0-M31