CVE-2015-3221 — neutron
CVE-2015-3221 is a Improper Input Validation vulnerability in neutron. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for neutron — see the affected versions and patch details below.
OpenStack Neutron Improper Input Validation vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
neutron🐍neutronReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
OpenStack Neutron before 2014.2.4 (juno) and 2015.1.x before 2015.1.1 (kilo), when using the IPTables firewall driver, allows remote authenticated users to cause a denial of service (L2 agent crash) by adding an address pair that is rejected by the ipset tool.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | neutron | ≥ 2000&&< 2014.2.4 | 2014.2.4pip install --upgrade 'neutron==2014.2.4' |
| 🐍PyPI | neutron | ≥ 2015.1.0&&< 2015.1.1 | 2015.1.1pip install --upgrade 'neutron==2015.1.1' |
Affected Products
neutronopenstackResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
GeniXCMS 0.0.3 - Cross-Site Scripting
by hyp3rlinx · Jun 24, 2015
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for neutron, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update neutron to 2014.2.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-3221 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux OpenStack Platform 6.0 (Juno) for RHEL 7 | openstack-neutron-0:2014.2.3-9.el7ost | RHSA-2015:1680 |
Frequently Asked Questions
Is CVE-2015-3221 in your dependencies?
Find it across PyPI, including transitive dependencies.