NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2015-3154 — zend-http

MEDIUM

CVE-2015-3154 is a medium-severity (CVSS 6.1) CWE-74 vulnerability in zendframework/zend-http. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for zendframework/zend-http — see the affected versions and patch details below.

Zenario CMS vulnerable to CRLF injection

Published
Updated
Affected
6 pkgs
Patched
6 / 6
Exploits
1 known
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs63th percentile — riskier than 63% of all scored CVEsHighest risk
0.00%0.50%1.01%1.51%0.3%1.0%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

6 pkgs affected
🐘zendframework/zend-http🐘zendframework/zend-http🐘zendframework/zendframework🐘zendframework/zendframework🐘zendframework/zendframework1🐘zendframework/zend-http

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

CRLF injection vulnerability in Zend\Mail (Zend_Mail) in Zend Framework before 1.12.12, 2.x before 2.3.8, and 2.4.x before 2.4.1 allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via CRLF sequences in the header of an email.

Affected Packages

6 total 6 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistzendframework/zend-http≥ 2.0.0beta4&&< 2.3.82.3.8composer require zendframework/zend-http:^2.3.8
🐘Packagistzendframework/zend-http≥ 2.4.0rc1&&< 2.4.12.4.1composer require zendframework/zend-http:^2.4.1
🐘Packagistzendframework/zendframework≥ 2.0.0beta4&&< 2.3.82.3.8composer require zendframework/zendframework:^2.3.8
🐘Packagistzendframework/zendframework≥ 2.4.0rc1&&< 2.4.12.4.1composer require zendframework/zendframework:^2.4.1
🐘Packagistzendframework/zendframework1all versions1.12.12composer require zendframework/zendframework1:^1.12.12
🐘Packagistzendframework/zend-httpall versions1.12.12composer require zendframework/zend-http:^1.12.12

Affected Products

1 product · 3 configurations
Application
zend frameworkzend
≥ 2.4.0 && < 2.4.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zendframework/zend-http, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update zendframework/zend-http to 2.3.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-3154 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

CRLF injection vulnerability in Zend\Mail (Zend_Mail) in Zend Framework before 1.12.12, 2.x before 2.3.8, and 2.4.x before 2.4.1 allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via CRLF sequences in the header of an email.
O3 Security · Impact-Aware SCA

Is CVE-2015-3154 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2015-3154: zend-http — Fixed in 2.3.8