NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2015-2316 — django

HIGHFix: django/django@5447709

CVE-2015-2316 is a high-severity (CVSS 7.5) CWE-399 vulnerability in django. A fix is available for django — see the affected versions and patch details below.

Django Denial-of-service possibility with strip_tags

Also known asGHSA-j3j3-jrfh-cm2wPYSEC-2015-18
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 25, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.8%probability of exploitation in next 30 days
Lower Risk-0.13%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
1.08%2.68%4.29%5.90%2.0%4.8%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍django🐍django🐍django

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The utils.html.strip_tags function in Django 1.6.x before 1.6.11, 1.7.x before 1.7.7, and 1.8.x before 1.8c1, when using certain versions of Python, allows remote attackers to cause a denial of service (infinite loop) by increasing the length of the input string.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIdjango≥ 1.6&&< 1.6.111.6.11pip install --upgrade 'django==1.6.11'
🐍PyPIdjango≥ 1.7&&< 1.7.71.7.7pip install --upgrade 'django==1.7.7'
🐍PyPIdjango≥ 1.8a1&&< 1.8c11.8c1pip install --upgrade 'django==1.8c1'

Affected Products

5 products · 36 configurations
OS
ubuntu linuxcanonical
4 versions
10.0412.0414.0414.10
Application
djangodjangoproject
19 versions
1.61.6.11.6.21.6.31.6.41.6.51.6.61.6.71.6.81.6.91.6.101.7
OS
fedorafedoraproject
1 version
22
OS
opensuseopensuse
1 version
13.2
OS
solarisoracle
1 version
11.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update django to 1.6.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-2316 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

The utils.html.strip_tags function in Django 1.6.x before 1.6.11, 1.7.x before 1.7.7, and 1.8.x before 1.8c1, when using certain versions of Python, allows remote attackers to cause a denial of service (infinite loop) by increasing the length of the input string.
O3 Security · Impact-Aware SCA

Is CVE-2015-2316 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2015-2316: django DoS — Fixed in 1.6.11