NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2015-1814 — jenkins-core

Fix: jenkinsci/jenkins@57e7888

CVE-2015-1814 is a CWE-264 vulnerability in org.jenkins-ci.main:jenkins-core. A fix is available for org.jenkins-ci.main:jenkins-core — see the affected versions and patch details below.

Jenkins allows for Privilege Escalation by Remote Authenticated Users

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs84th percentile — riskier than 84% of all scored CVEsHighest risk
0.00%0.99%1.99%2.98%0.2%2.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
☕org.jenkins-ci.main:jenkins-core☕org.jenkins-ci.main:jenkins-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The API token-issuing service in Jenkins before 1.606 and LTS before 1.596.2 allows remote attackers to gain privileges via a "forced API token change" involving anonymous users.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.main:jenkins-core≥ 1.597&&< 1.6061.606org.jenkins-ci.main:jenkins-core:1.606
☕Mavenorg.jenkins-ci.main:jenkins-coreall versions1.596.2org.jenkins-ci.main:jenkins-core:1.596.2

Affected Products

2 products · 3 configurations
Application
jenkinsjenkins
≤ 1.605
1 version
1.596.1
Application
openshiftredhat
≤ 3.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.main:jenkins-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.main:jenkins-core to 1.606 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-1814 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat OpenShift Enterprise 2.2jenkins-0:1.609.1-1.el6opRHSA-2015:1844
Red Hat OpenShift Enterprise 3.1atomic-openshift-0:3.1.1.6-1.git.0.b57e8bd.el7aosRHSA-2016:0070

Frequently Asked Questions

The API token-issuing service in Jenkins before 1.606 and LTS before 1.596.2 allows remote attackers to gain privileges via a "forced API token change" involving anonymous users.
O3 Security · Impact-Aware SCA

Is CVE-2015-1814 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2015-1814: jenkins-core — Fixed in 1.606