NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎 RubyGems
Not in CISA KEV

CVE-2015-1585 — fat_free_crm

Fix: fatfreecrm/fat_free_crm@86fd7f9

CVE-2015-1585 is a Cross-Site Request Forgery (CSRF) vulnerability in fat_free_crm. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for fat_free_crm — see the affected versions and patch details below.

Fat Free CRM Cross-Site Request Forgery vulnerability

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs66th percentile — riskier than 66% of all scored CVEsHighest risk
0.00%0.53%1.06%1.59%0.3%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
💎fat_free_crm

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

Fat Free CRM before 0.13.6 allows remote attackers to conduct cross-site request forgery (CSRF) attacks via a request without the authenticity_token, as demonstrated by a crafted HTML page that creates a new administrator account.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsfat_free_crmall versions0.13.6bundle update fat_free_crm --conservative

Affected Products

1 product · 1 configurations
Application
fat free crmfatfreecrm
≤ 0.13.5
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for fat_free_crm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update fat_free_crm to 0.13.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-1585 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Fat Free CRM before 0.13.6 allows remote attackers to conduct cross-site request forgery (CSRF) attacks via a request without the authenticity_token, as demonstrated by a crafted HTML page that creates a new administrator account.
O3 Security · Impact-Aware SCA

Is CVE-2015-1585 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2015-1585: fat_free_crm CSRF — Fixed in 0.13.6