CVE-2015-10077 — silverstripe-kapost-bridge
CRITICALFix: webbuilders-group/silverstripe-kapost-bridge@2e14b0fCVE-2015-10077 is a critical-severity (CVSS 9.8) SQL Injection vulnerability in webbuilders-group/silverstripe-kapost-bridge. A fix is available for webbuilders-group/silverstripe-kapost-bridge — see the affected versions and patch details below.
SQL injection in webbuilders-group silverstripe-kapost-bridge
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2015-10077.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
webbuilders-group/silverstripe-kapost-bridgeReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A vulnerability was found in webbuilders-group silverstripe-kapost-bridge 0.3.3. It has been declared as critical. Affected by this vulnerability is the function index/getPreview of the file code/control/KapostService.php. The manipulation leads to sql injection. The attack can be launched remotely. Upgrading to version 0.4.0 is able to address this issue. The name of the patch is 2e14b0fd0ea35034f90890f364b130fb4645ff35. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220471.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | webbuilders-group/silverstripe-kapost-bridge | all versions | 0.4.0composer require webbuilders-group/silverstripe-kapost-bridge:^0.4.0 |
Affected Products
silverstripe-kapost-bridgewebbuildersgroupDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for webbuilders-group/silverstripe-kapost-bridge, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update webbuilders-group/silverstripe-kapost-bridge to 0.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-10077 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Frequently Asked Questions
Is CVE-2015-10077 in your dependencies?
Find it across Packagist, including transitive dependencies.