NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2015-0276 — kallithea

HIGH

CVE-2015-0276 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in kallithea. A fix is available for kallithea — see the affected versions and patch details below.

Kallithea cross-site request forgery (CSRF) vulnerability

Also known asPYSEC-2017-16
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.00%0.41%0.82%1.23%0.3%0.7%May 26Sep 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍kallithea

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site request forgery (CSRF) vulnerability in Kallithea before 0.2.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIkallitheaall versions0.2pip install --upgrade 'kallithea==0.2'

Affected Products

1 product · 1 configurations
Application
kallitheakallithea-scm
≤ 0.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for kallithea, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update kallithea to 0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-0276 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Cross-site request forgery (CSRF) vulnerability in Kallithea before 0.2.
O3 Security · Impact-Aware SCA

Is CVE-2015-0276 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2015-0276: kallithea CSRF — Fixed in 0.2