CVE-2015-0222 is a high-severity (CVSS 7.5) CWE-17 vulnerability in django. A fix is available for django — see the affected versions and patch details below.
Django database denial-of-service with ModelMultipleChoiceField
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
django🐍djangoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
ModelMultipleChoiceField in Django 1.6.x before 1.6.10 and 1.7.x before 1.7.3, when show_hidden_initial is set to True, allows remote attackers to cause a denial of service by submitting duplicate values, which triggers a large number of SQL queries.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | django | ≥ 1.6&&< 1.6.10 | 1.6.10pip install --upgrade 'django==1.6.10' |
| 🐍PyPI | django | ≥ 1.7&&< 1.7.3 | 1.7.3pip install --upgrade 'django==1.7.3' |
Affected Products
ubuntu linuxcanonicaldjangodjangoprojectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update django to 1.6.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-0222 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2015-0222 in your dependencies?
Find it across PyPI, including transitive dependencies.