NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2015-0219 — django

MEDIUMFix: django/django@41b4bc7

CVE-2015-0219 is a medium-severity (CVSS 5.3) CWE-17 vulnerability in django. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for django — see the affected versions and patch details below.

Django WSGI Header Spoofing Vulnerability

Also known asGHSA-7qfw-j7hp-v45gPYSEC-2015-4
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
1 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
7.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs94th percentile — riskier than 94% of all scored CVEsHighest risk
4.20%5.33%6.47%7.61%4.8%7.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍django🐍django🐍django

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Django before 1.4.18, 1.6.x before 1.6.10, and 1.7.x before 1.7.3 allows remote attackers to spoof WSGI headers by using an _ (underscore) character instead of a - (dash) character in an HTTP header, as demonstrated by an X-Auth_User header.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIdjangoall versions1.4.18pip install --upgrade 'django==1.4.18'
🐍PyPIdjango≥ 1.6&&< 1.6.101.6.10pip install --upgrade 'django==1.6.10'
🐍PyPIdjango≥ 1.7&&< 1.7.31.7.3pip install --upgrade 'django==1.7.3'

Affected Products

1 product · 14 configurations
Application
djangodjangoproject
≤ 1.4.17
13 versions
1.61.6.11.6.21.6.31.6.41.6.51.6.61.6.71.6.81.6.91.71.7.1
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update django to 1.4.18 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-0219 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Frequently Asked Questions

Django before 1.4.18, 1.6.x before 1.6.10, and 1.7.x before 1.7.3 allows remote attackers to spoof WSGI headers by using an _ (underscore) character instead of a - (dash) character in an HTTP header, as demonstrated by an X-Auth_User header.
O3 Security · Impact-Aware SCA

Is CVE-2015-0219 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2015-0219: django — Fixed in 1.4.18