NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2014-9970 — jasypt

HIGH

CVE-2014-9970 is a high-severity (CVSS 7.5) Information Exposure vulnerability in org.jasypt:jasypt. A fix is available for org.jasypt:jasypt — see the affected versions and patch details below.

Exposure of Sensitive Information to an Unauthorized Actor in Apache Jasypt

Also known asGHSA-r5c2-rxh2-f5h2
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs84th percentile — riskier than 84% of all scored CVEsHighest risk
0.18%1.10%2.03%2.95%0.7%2.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jasypt:jasypt

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

jasypt before 1.9.2 allows a timing attack against the password hash comparison.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jasypt:jasyptall versions1.9.2org.jasypt:jasypt:1.9.2

Affected Products

1 product · 1 configurations
Application
jasyptjasypt_project
≤ 1.9.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jasypt:jasypt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jasypt:jasypt to 1.9.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-9970 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Data Grid 7.1.2see advisoryRHSA-2018:0294
Red Hat JBoss BPMS 6.4jasyptRHSA-2017:2546
Red Hat JBoss BRMS 6.4jasyptRHSA-2017:2547
Red Hat JBoss EAP 7see advisoryRHSA-2017:2810
Red Hat JBoss Enterprise Application Platform 7.0 for RHEL 6eap7-artemis-native-0:1.1.0-13.redhat_4.ep7.el6RHSA-2017:2809
Red Hat JBoss Enterprise Application Platform 7.0 for RHEL 6eap7-jboss-ec2-eap-0:7.0.8-1.GA_redhat_1.ep7.el6RHSA-2017:2811
Red Hat JBoss Enterprise Application Platform 7.0 for RHEL 7eap7-artemis-native-0:1.1.0-13.redhat_4.ep7.el7RHSA-2017:2808
Red Hat Single Sign-On 7.1see advisoryRHSA-2017:2906

Frequently Asked Questions

jasypt before 1.9.2 allows a timing attack against the password hash comparison.
O3 Security · Impact-Aware SCA

Is CVE-2014-9970 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2014-9970: jasypt — Fixed in 1.9.2