NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2014-8328 — dce

MEDIUM

CVE-2014-8328 is a medium-severity (CVSS 5.3) Information Exposure vulnerability in t3/dce. A fix is available for t3/dce — see the affected versions and patch details below.

DCE extension for Typo3 Discloses Environment Information

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs76th percentile — riskier than 76% of all scored CVEsHighest risk
0.00%0.69%1.39%2.08%0.3%1.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘t3/dce

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The default configuration in the Dynamic Content Elements (dce) extension before 0.11.5 for TYPO3 allows remote attackers to obtain sensitive installation environment information by reading the update check request.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistt3/dceall versions0.11.5composer require t3/dce:^0.11.5

Affected Products

1 product · 5 configurations
Application
dynamic content elementsdynamic_content_elements_project
≥ 0.11.0 && ≤ 0.10.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for t3/dce, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update t3/dce to 0.11.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-8328 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

The default configuration in the Dynamic Content Elements (dce) extension before 0.11.5 for TYPO3 allows remote attackers to obtain sensitive installation environment information by reading the update check request.
O3 Security · Impact-Aware SCA

Is CVE-2014-8328 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2014-8328: dce Info Disclosure — Fixed in 0.11.5