CVE-2014-7816 — undertow-core
CVE-2014-7816 is a Path Traversal vulnerability in io.undertow:undertow-core. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for io.undertow:undertow-core — see the affected versions and patch details below.
Improper Limitation of a Pathname to a Restricted Directory in JBoss Undertow
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
io.undertow:undertow-core☕io.undertow:undertow-core☕io.undertow:undertow-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Directory traversal vulnerability in JBoss Undertow 1.0.x before 1.0.17, 1.1.x before 1.1.0.CR5, and 1.2.x before 1.2.0.Beta3, when running on Windows, allows remote attackers to read arbitrary files via a .. (dot dot) in a resource URI.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | io.undertow:undertow-core | ≥ 1.0.0&&< 1.0.17 | 1.0.17io.undertow:undertow-core:1.0.17 |
| ☕Maven | io.undertow:undertow-core | ≥ 1.1.0.Beta1&&< 1.1.0.CR5 | 1.1.0.CR5io.undertow:undertow-core:1.1.0.CR5 |
| ☕Maven | io.undertow:undertow-core | ≥ 1.2.0.Beta1&&< 1.2.0.Beta3 | 1.2.0.Beta3io.undertow:undertow-core:1.2.0.Beta3 |
Affected Products
undertowredhatResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.undertow:undertow-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update io.undertow:undertow-core to 1.0.17 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-7816 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is CVE-2014-7816 in your dependencies?
Find it across Maven, including transitive dependencies.