NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2014-6289 — yag

Fix: YAG-Gallery/yag@4ab6ca1

CVE-2014-6289 is a CWE-264 vulnerability in dl/yag. A fix is available for dl/yag — see the affected versions and patch details below.

yag and pt_extbase extensions for TYPO3 allow remote attackers to bypass access restrictions

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs75th percentile — riskier than 75% of all scored CVEsHighest risk
0.00%0.67%1.35%2.02%0.2%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
🐘dl/yag🐘punktde/pt_extbase

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The Ajax dispatcher for Extbase in the Yet Another Gallery (yag) extension before 3.0.1 and Tools for Extbase development (pt_extbase) extension before 1.5.1 allows remote attackers to bypass access restrictions and execute arbitrary controller actions via unspecified vectors.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistdl/yagall versions3.0.1composer require dl/yag:^3.0.1
🐘Packagistpunktde/pt_extbaseall versions1.5.1composer require punktde/pt_extbase:^1.5.1

Affected Products

2 products · 2 configurations
Application
yet another gallerydaniel_lienert
≤ 3.0.0
range
Application
tools for extbase developmenmichael_knoll
≤ 1.5.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for dl/yag, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update dl/yag to 3.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-6289 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The Ajax dispatcher for Extbase in the Yet Another Gallery (yag) extension before 3.0.1 and Tools for Extbase development (pt_extbase) extension before 1.5.1 allows remote attackers to bypass access restrictions and execute arbitrary controller actions via unspecified vectors.
O3 Security · Impact-Aware SCA

Is CVE-2014-6289 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2014-6289: yag — Fixed in 3.0.1