NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2014-5326 — dwr

CVE-2014-5326 is a Cross-site Scripting (XSS) vulnerability in org.directwebremoting:dwr. A fix is available for org.directwebremoting:dwr — see the affected versions and patch details below.

Improper Neutralization of Input During Web Page Generation in Direct Web Remoting

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs67th percentile — riskier than 67% of all scored CVEsHighest risk
0.00%0.55%1.10%1.65%0.2%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
☕org.directwebremoting:dwr☕org.directwebremoting:dwr

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in Direct Web Remoting (DWR) through 2.0.10 and 3.x through 3.0.RC2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.directwebremoting:dwrall versions2.0.11org.directwebremoting:dwr:2.0.11
☕Mavenorg.directwebremoting:dwr≥ 3.0.M1&&< 3.0.RC33.0.RC3org.directwebremoting:dwr:3.0.RC3

Affected Products

1 product · 3 configurations
Application
direct web remotingdirectwebremoting
≤ 2.0.10
1 version
3.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.directwebremoting:dwr, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.directwebremoting:dwr to 2.0.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-5326 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in Direct Web Remoting (DWR) through 2.0.10 and 3.x through 3.0.RC2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
O3 Security · Impact-Aware SCA

Is CVE-2014-5326 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2014-5326: dwr XSS — Fixed in 2.0.11