CVE-2014-5013 — dompdf
HIGHCVE-2014-5013 is a high-severity (CVSS 8.8) remote code execution vulnerability in dompdf/dompdf. A fix is available for dompdf/dompdf — see the affected versions and patch details below.
DOMPDF Remote Code Execution
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
dompdf/dompdfReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
DOMPDF before 0.6.2 allows remote code execution, a related issue to CVE-2014-2383.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | dompdf/dompdf | ≥ 0.6&&< 0.6.2 | 0.6.2composer require dompdf/dompdf:^0.6.2 |
Affected Products
dompdfdompdf_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for dompdf/dompdf, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update dompdf/dompdf to 0.6.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-5013 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2014-5013 in your dependencies?
Find it across Packagist, including transitive dependencies.