NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎 RubyGems
Not in CISA KEV

CVE-2014-4326 — logstash

CVE-2014-4326 is a OS Command Injection vulnerability in logstash. A fix is available for logstash — see the affected versions and patch details below.

Elasticsearch Logstash allows remote attackers to execute arbitrary commands

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs88th percentile — riskier than 88% of all scored CVEsHighest risk
0.16%1.44%2.73%4.02%0.9%3.3%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
💎logstash

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

Elasticsearch Logstash 1.0.14 through 1.4.x before 1.4.2 allows remote attackers to execute arbitrary commands via a crafted event in (1) zabbix.rb or (2) nagios_nsca.rb in outputs/.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemslogstash≥ 1.0.14&&< 1.4.21.4.2bundle update logstash --conservative

Affected Products

1 product · 27 configurations
Application
logstashelastic
27 versions
1.0.141.0.151.0.161.0.171.1.01.1.0.11.1.11.1.21.1.31.1.41.1.51.1.6

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for logstash, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update logstash to 1.4.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-4326 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Elasticsearch Logstash 1.0.14 through 1.4.x before 1.4.2 allows remote attackers to execute arbitrary commands via a crafted event in (1) `zabbix.rb` or (2) `nagios_nsca.rb` in `outputs/`.
O3 Security · Impact-Aware SCA

Is CVE-2014-4326 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2014-4326: logstash — Fixed in 1.4.2