NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2014-3994 — djblets

MEDIUMFix: djblets/djblets@50000d0

CVE-2014-3994 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in djblets. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for djblets — see the affected versions and patch details below.

Djiblets Cross-site scripting Vulnerability via JSON Objects

Also known asPYSEC-2014-78
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs84th percentile — riskier than 84% of all scored CVEsHighest risk
0.04%1.01%1.99%2.96%0.6%2.4%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍djblets🐍djblets

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

A cross-site scripting (XSS) vulnerability in util/templatetags/djblets_js.py in Djblets before 0.7.30 and 0.8.x before 0.8.3 for Django, as used in Review Board, allows remote attackers to inject arbitrary web script or HTML via a JSON object, as demonstrated by the name field when changing a user name.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIdjbletsall versions0.7.30pip install --upgrade 'djblets==0.7.30'
🐍PyPIdjblets≥ 0.8&&< 0.8.30.8.3pip install --upgrade 'djblets==0.8.3'

Affected Products

2 products · 6 configurations
Application
djbletsreviewboard
≤ 0.7.29
4 versions
0.7.270.7.280.8.10.8.2
Application
reviewboardreviewboard
all
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for djblets, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update djblets to 0.7.30 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-3994 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

A cross-site scripting (XSS) vulnerability in `util/templatetags/djblets_js.py` in Djblets before 0.7.30 and 0.8.x before 0.8.3 for Django, as used in Review Board, allows remote attackers to inject arbitrary web script or HTML via a JSON object, as demonstrated by the name field when changing a user name.
O3 Security · Impact-Aware SCA

Is CVE-2014-3994 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2014-3994: djblets XSS — Fixed in 0.7.30