NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2014-3545 — moodle

Fix: moodle/moodle@155bc75

CVE-2014-3545 is a Code Injection vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Moodle remote code execution via quiz questions

Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs78th percentile — riskier than 78% of all scored CVEsHighest risk
0.78%1.26%1.74%2.22%1.3%1.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

4 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allows remote authenticated users to execute arbitrary code via a calculated question in a quiz.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 2.7.0&&< 2.7.12.7.1composer require moodle/moodle:^2.7.1
🐘Packagistmoodle/moodle≥ 2.6.0&&< 2.6.42.6.4composer require moodle/moodle:^2.6.4
🐘Packagistmoodle/moodle≥ 2.5.0&&< 2.5.72.5.7composer require moodle/moodle:^2.5.7
🐘Packagistmoodle/moodle≥ 2.4.0&&< 2.4.112.4.11composer require moodle/moodle:^2.4.11

Affected Products

1 product · 35 configurations
Application
moodlemoodle
≤ 2.3.11
34 versions
2.3.02.3.12.3.22.3.32.3.42.3.52.3.62.3.72.3.82.3.92.3.102.4.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 2.7.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-3545 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allows remote authenticated users to execute arbitrary code via a calculated question in a quiz.
O3 Security · Impact-Aware SCA

Is CVE-2014-3545 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2014-3545: moodle RCE — Fixed in 2.7.1