NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2014-3542 — moodle

Fix: moodle/moodle@78ed99e

CVE-2014-3542 is a Information Exposure vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Moodle allows remote attackers to read arbitrary files

Published
Updated
Affected
5 pkgs
Patched
4 / 5
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs72th percentile — riskier than 72% of all scored CVEsHighest risk
0.00%0.62%1.24%1.85%0.4%1.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

5 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

mod/lti/service.php in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allows remote attackers to read arbitrary files via an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.

Affected Packages

5 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodleall versionsNo fix
🐘Packagistmoodle/moodle≥ 2.4.0&&< 2.4.112.4.11composer require moodle/moodle:^2.4.11
🐘Packagistmoodle/moodle≥ 2.5.0&&< 2.5.72.5.7composer require moodle/moodle:^2.5.7
🐘Packagistmoodle/moodle≥ 2.6.0&&< 2.6.42.6.4composer require moodle/moodle:^2.6.4
🐘Packagistmoodle/moodle≥ 2.7.0&&< 2.7.12.7.1composer require moodle/moodle:^2.7.1

Affected Products

1 product · 35 configurations
Application
moodlemoodle
≤ 2.3.11
34 versions
2.3.02.3.12.3.22.3.32.3.42.3.52.3.62.3.72.3.82.3.92.3.102.4.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2014-3542; check the affected-versions list above or the advisory for the patched release of moodle/moodle, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

mod/lti/service.php in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allows remote attackers to read arbitrary files via an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.
O3 Security · Impact-Aware SCA

Is CVE-2014-3542 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2014-3542: moodle XXE — Fixed in 2.4.11