CVE-2014-3541 — moodle
Fix: moodle/moodle@3fe1059CVE-2014-3541 is a Code Injection vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
Moodle vulnerable to PHP object injection attacks
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The Repositories component in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allows remote attackers to conduct PHP object injection attacks and execute arbitrary code via serialized data associated with an add-on.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | all versions | 2.4.11composer require moodle/moodle:^2.4.11 |
| 🐘Packagist | moodle/moodle | ≥ 2.5.0&&< 2.5.7 | 2.5.7composer require moodle/moodle:^2.5.7 |
| 🐘Packagist | moodle/moodle | ≥ 2.6.0&&< 2.6.4 | 2.6.4composer require moodle/moodle:^2.6.4 |
| 🐘Packagist | moodle/moodle | ≥ 2.7.0&&< 2.7.1 | 2.7.1composer require moodle/moodle:^2.7.1 |
Affected Products
moodlemoodleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 2.4.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-3541 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2014-3541 in your dependencies?
Find it across Packagist, including transitive dependencies.