NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💧 Hex
Not in CISA KEV

CVE-2014-2829 — MongooseIM

Fix: esl/MongooseIM@586d96c

CVE-2014-2829 is a CWE-264 vulnerability in MongooseIM. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for MongooseIM — see the affected versions and patch details below.

Erlang Solutions MongooseIM vulnerable to denial of service (DoS) via crafted XMPP stream

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs81th percentile — riskier than 81% of all scored CVEsHighest risk
0.00%0.84%1.67%2.51%0.5%2.0%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
💧MongooseIM

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Hex packages — download data is not available via public APIs for these ecosystems.

Description

Erlang Solutions MongooseIM through 1.3.1 rev. 2 does not properly restrict the processing of compressed XML elements, which allows remote attackers to cause a denial of service (resource consumption) via a crafted XMPP stream, aka an "xmppbomb" attack.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💧HexMongooseIMall versions1.3.2mix deps.update MongooseIM

Affected Products

1 product · 5 configurations
Application
mongooseimerlang-solutions
≤ 1.3.1
4 versions
1.2.11.2.21.3.01.3.1
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for MongooseIM, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update MongooseIM to 1.3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-2829 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

Erlang Solutions MongooseIM through 1.3.1 rev. 2 does not properly restrict the processing of compressed XML elements, which allows remote attackers to cause a denial of service (resource consumption) via a crafted XMPP stream, aka an "xmppbomb" attack.
O3 Security · Impact-Aware SCA

Is CVE-2014-2829 in your dependencies?

Find it across Hex, including transitive dependencies.

CVE-2014-2829: MongooseIM DoS — Fixed in 1.3.2