CVE-2014-2683 — zendframework1
CVE-2014-2683 is a CWE-17 vulnerability in zendframework/zendframework1. A fix is available for zendframework/zendframework1 — see the affected versions and patch details below.
Several Zend Products Vulnerable to XXE and XEE attacks
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
zendframework/zendframework1🐘zendframework/zendopenid🐘zendframework/zendrest🐘zendframework/zendservice-audioscrobbler🐘zendframework/zendservice-nirvanix🐘zendframework/zendservice-slideshare🐘zendframework/zendservice-technorati🐘zendframework/zendservice-windowsazure+2 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Zend Framework 1 (ZF1) before 1.12.4, Zend Framework 2 before 2.1.6 and 2.2.x before 2.2.6, ZendOpenId, ZendRest, ZendService_AudioScrobbler, ZendService_Nirvanix, ZendService_SlideShare, ZendService_Technorati, and ZendService_WindowsAzure before 2.0.2, ZendService_Amazon before 2.0.3, and ZendService_Api before 1.0.0 allow remote attackers to cause a denial of service (CPU consumption) via (1) recursive or (2) circular references in an XML entity definition in an XML DOCTYPE declaration, aka an XML Entity Expansion (XEE) attack. NOTE: this issue exists because of an incomplete fix for CVE-2012-6532.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | zendframework/zendframework1 | all versions | 1.12.4composer require zendframework/zendframework1:^1.12.4 |
| 🐘Packagist | zendframework/zendopenid | all versions | 2.0.2composer require zendframework/zendopenid:^2.0.2 |
| 🐘Packagist | zendframework/zendrest | all versions | 2.0.2composer require zendframework/zendrest:^2.0.2 |
| 🐘Packagist | zendframework/zendservice-audioscrobbler | all versions | 2.0.2composer require zendframework/zendservice-audioscrobbler:^2.0.2 |
| 🐘Packagist | zendframework/zendservice-nirvanix | all versions | 2.0.2composer require zendframework/zendservice-nirvanix:^2.0.2 |
| 🐘Packagist | zendframework/zendservice-slideshare | all versions | 2.0.2composer require zendframework/zendservice-slideshare:^2.0.2 |
Affected Products
zend frameworkzendzendopenidzendzendrestzendzendservice amazonzendzendservice apizendzendservice audioscrobblerzendDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zendframework/zendframework1, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update zendframework/zendframework1 to 1.12.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-2683 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2014-2683 in your dependencies?
Find it across Packagist, including transitive dependencies.