NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2014-2383 — dompdf

Fix: dompdf/dompdf@23a6939

CVE-2014-2383 is a Information Exposure vulnerability in dompdf/dompdf. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for dompdf/dompdf — see the affected versions and patch details below.

DOMPDF Arbitrary File Read

Also known asGHSA-qr6q-w4gj-3865
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
39.4%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
38.9%39.2%39.5%39.9%39.4%39.4%Jul 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐘dompdf/dompdf

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

dompdf.php in dompdf before 0.6.1, when DOMPDF_ENABLE_PHP is enabled, allows context-dependent attackers to bypass chroot protections and read arbitrary files via a PHP protocol and wrappers in the input_file parameter, as demonstrated by a php://filter/read=convert.base64-encode/resource in the input_file parameter.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistdompdf/dompdf≥ 0.6.0&&< 0.6.10.6.1composer require dompdf/dompdf:^0.6.1

Affected Products

1 product · 1 configurations
Application
dompdfdompdf
≤ 0.6.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-33004webappsphp✓ Verified

dompdf 0.6.0 - 'dompdf.php?read' Arbitrary File Read

by Portcullis · Apr 24, 2014

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for dompdf/dompdf, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update dompdf/dompdf to 0.6.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-2383 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

How to detect CVE-2014-2383

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2014-2383 -u https://target
Template
Dompdf < v0.6.0 - Local File Inclusion
Severity
medium
Impact
The vulnerability can lead to unauthorized access to sensitive files, remote code execution, and compromise of the affected system.
Remediation
Upgrade Dompdf to a version higher than v0.6.0 to mitigate the vulnerability.

Template by ProjectDiscovery nuclei-templates (0x_Akoko, akincibor, ritikchaddha), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

dompdf.php in dompdf before 0.6.1, when DOMPDF_ENABLE_PHP is enabled, allows context-dependent attackers to bypass chroot protections and read arbitrary files via a PHP protocol and wrappers in the input_file parameter, as demonstrated by a php://filter/read=convert.base64-encode/resource in the input_file parameter.
O3 Security · Impact-Aware SCA

Is CVE-2014-2383 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2014-2383: dompdf — Fixed in 0.6.1