CVE-2014-2053 — getid3
Fix: JamesHeinrich/getID3@afbdaa0CVE-2014-2053 is a security vulnerability in james-heinrich/getid3. A fix is available for james-heinrich/getid3 — see the affected versions and patch details below.
getID3 is vulnerable to XML External Entity (XXE)
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
james-heinrich/getid3Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
getID3() before 1.9.8, as used in ownCloud Server before 5.0.15 and 6.0.x before 6.0.2, allows remote attackers to read arbitrary files, cause a denial of service, or possibly have other impact via an XML External Entity (XXE) attack.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | james-heinrich/getid3 | all versions | 1.9.9composer require james-heinrich/getid3:^1.9.9 |
Affected Products
getid3getid3owncloud serverowncloudDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for james-heinrich/getid3, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update james-heinrich/getid3 to 1.9.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-2053 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2014-2053 in your dependencies?
Find it across Packagist, including transitive dependencies.