NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2014-1938 — rply

MEDIUMFix: alex/rply@76d268a

CVE-2014-1938 is a medium-severity (CVSS 5.5) CWE-59 vulnerability in rply. A fix is available for rply — see the affected versions and patch details below.

Link Following in rply

Also known asGHSA-m8qc-mf6p-pfq9PYSEC-2019-202
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs33th percentile — riskier than 33% of all scored CVEsHighest risk
0.00%0.30%0.60%0.90%0.1%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍rply

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

python-rply before 0.7.4 insecurely creates temporary files.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIrplyall versions0.7.4pip install --upgrade 'rply==0.7.4'

Affected Products

1 product · 1 configurations
Application
rplyrply_project
< 0.7.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for rply, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update rply to 0.7.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-1938 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

python-rply before 0.7.4 insecurely creates temporary files.
O3 Security · Impact-Aware SCA

Is CVE-2014-1938 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2014-1938: rply — Fixed in 0.7.4