CVE-2014-1868 — org.restlet
CVE-2014-1868 is a security vulnerability in org.restlet.jse:org.restlet. A fix is available for org.restlet.jse:org.restlet — see the affected versions and patch details below.
Moderate severity vulnerability that affects org.restlet.jse:org.restlet
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.restlet.jse:org.restletReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Restlet Framework 2.1.x before 2.1.7 and 2.x.x before 2.2 RC1, when using XMLRepresentation or XML serializers, allows attackers to cause a denial of service via an XML Entity Expansion (XEE) attack.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.restlet.jse:org.restlet | ≥ 2.1.0&&< 2.1.7 | 2.1.7org.restlet.jse:org.restlet:2.1.7 |
Affected Products
restlet frameworkrestletDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.restlet.jse:org.restlet, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.restlet.jse:org.restlet to 2.1.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-1868 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2014-1868 in your dependencies?
Find it across Maven, including transitive dependencies.