NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

CVE-2014-0474 — django

CRITICALFix: django/django@5f0829a

CVE-2014-0474 is a critical-severity (CVSS 9.8) CWE-399 vulnerability in django. A fix is available for django — see the affected versions and patch details below.

Django Vulnerable to MySQL Injection

Also known asGHSA-wqjj-hx84-v449PYSEC-2014-3
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
3.46%4.10%4.74%5.38%4.0%4.9%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍django🐍django🐍django

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The (1) FilePathField, (2) GenericIPAddressField, and (3) IPAddressField model field classes in Django before 1.4.11, 1.5.x before 1.5.6, 1.6.x before 1.6.3, and 1.7.x before 1.7 beta 2 do not properly perform type conversion, which allows remote attackers to have unspecified impact and vectors, related to "MySQL typecasting."

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIdjangoall versions1.4.11pip install --upgrade 'django==1.4.11'
🐍PyPIdjango≥ 1.5&&< 1.5.61.5.6pip install --upgrade 'django==1.5.6'
🐍PyPIdjango≥ 1.6&&< 1.6.31.6.3pip install --upgrade 'django==1.6.3'

Affected Products

2 products · 28 configurations
OS
ubuntu linuxcanonical
5 versions
10.0412.0412.1013.1014.04
Application
djangodjangoproject
≤ 1.4.10
20 versions
1.41.4.11.4.21.4.31.4.41.4.51.4.61.4.71.4.81.4.91.51.5.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update django to 1.4.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-0474 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
OpenStack 3 for RHEL 6Django14-0:1.4.11-1.el6ostRHSA-2014:0457
OpenStack 4 for RHEL 6Django14-0:1.4.11-1.el6ostRHSA-2014:0456

Frequently Asked Questions

The (1) FilePathField, (2) GenericIPAddressField, and (3) IPAddressField model field classes in Django before 1.4.11, 1.5.x before 1.5.6, 1.6.x before 1.6.3, and 1.7.x before 1.7 beta 2 do not properly perform type conversion, which allows remote attackers to have unspecified impact and vectors, related to "MySQL typecasting."
O3 Security · Impact-Aware SCA

Is CVE-2014-0474 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2014-0474: django — Fixed in 1.4.11