CVE-2014-0472 is a critical-severity (CVSS 9.8) Code Injection vulnerability in django. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for django — see the affected versions and patch details below.
Code Injection in Django
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
django🐍django🐍djangoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
The django.core.urlresolvers.reverse function in Django before 1.4.11, 1.5.x before 1.5.6, 1.6.x before 1.6.3, and 1.7.x before 1.7 beta 2 allows remote attackers to import and execute arbitrary Python modules by leveraging a view that constructs URLs using user input and a "dotted Python path."
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | django | all versions | 1.4.11pip install --upgrade 'django==1.4.11' |
| 🐍PyPI | django | ≥ 1.5&&< 1.5.6 | 1.5.6pip install --upgrade 'django==1.5.6' |
| 🐍PyPI | django | ≥ 1.6&&< 1.6.3 | 1.6.3pip install --upgrade 'django==1.6.3' |
Affected Products
ubuntu linuxcanonicaldjangodjangoprojectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update django to 1.4.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-0472 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| OpenStack 3 for RHEL 6 | Django14-0:1.4.11-1.el6ost | RHSA-2014:0457 |
| OpenStack 4 for RHEL 6 | Django14-0:1.4.11-1.el6ost | RHSA-2014:0456 |
Frequently Asked Questions
Is CVE-2014-0472 in your dependencies?
Find it across PyPI, including transitive dependencies.