CVE-2014-0214 — moodle
Fix: moodle/moodle@14c16a4CVE-2014-0214 is a Improper Authentication vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
Moodle creates a MoodleMobile web-service token with an infinite lifetime
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
login/token.php in Moodle through 2.3.11, 2.4.x before 2.4.10, 2.5.x before 2.5.6, and 2.6.x before 2.6.3 creates a MoodleMobile web-service token with an infinite lifetime, which makes it easier for remote attackers to hijack sessions via a brute-force attack.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | all versions | 2.4.10composer require moodle/moodle:^2.4.10 |
| 🐘Packagist | moodle/moodle | ≥ 2.5.0&&< 2.5.6 | 2.5.6composer require moodle/moodle:^2.5.6 |
| 🐘Packagist | moodle/moodle | ≥ 2.6.0&&< 2.6.3 | 2.6.3composer require moodle/moodle:^2.6.3 |
Affected Products
moodlemoodleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 2.4.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-0214 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2014-0214 in your dependencies?
Find it across Packagist, including transitive dependencies.