CVE-2014-0135 — kafo
CVE-2014-0135 is a CWE-264 vulnerability in kafo. A fix is available for kafo — see the affected versions and patch details below.
Kafo allows local users to obtain passwords and other sensitive information by reading default_values.yaml
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
kafo💎kafoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Kafo before 0.3.17 and 0.4.x before 0.5.2, as used by Foreman, uses world-readable permissions for default_values.yaml, which allows local users to obtain passwords and other sensitive information by reading the file.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | kafo | all versions | 0.3.17bundle update kafo --conservative |
| 💎RubyGems | kafo | ≥ 0.4.0&&< 0.5.2 | 0.5.2bundle update kafo --conservative |
Affected Products
kafotheforemanDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for kafo, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update kafo to 0.3.17 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-0135 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Satellite 6.0 | rubygem-kafo-0:0.6.4-2.el6sat | RHEA-2014:1175 |
Frequently Asked Questions
Is CVE-2014-0135 in your dependencies?
Find it across RubyGems, including transitive dependencies.