CVE-2013-7078 — cms-core
CVE-2013-7078 is a Cross-site Scripting (XSS) vulnerability in typo3/cms-core. A fix is available for typo3/cms-core — see the affected versions and patch details below.
TYPO3 Cross-site scripting (XSS) vulnerability in the Extbase Framework
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
typo3/cms-core🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting (XSS) vulnerability in the errorAction method in the ActionController base class in the Extbase Framework in TYPO3 4.5.0 through 4.5.31, 4.7.0 through 4.7.16, 6.0.0 through 6.0.11, and 6.1.0 through 6.1.6, when the Rewritten Property Mapper is enabled, allows remote attackers to inject arbitrary web script or HTML via unspecified input, which is returned in an error message. NOTE: this might be the same vulnerability as CVE-2013-7072.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms-core | ≥ 4.5.0&&< 4.5.31 | 4.5.31composer require typo3/cms-core:^4.5.31 |
| 🐘Packagist | typo3/cms-core | ≥ 4.7.0&&< 4.7.16 | 4.7.16composer require typo3/cms-core:^4.7.16 |
| 🐘Packagist | typo3/cms-core | ≥ 6.1.0&&< 6.1.6 | 6.1.6composer require typo3/cms-core:^6.1.6 |
| 🐘Packagist | typo3/cms-core | ≥ 6.0.0&&< 6.0.11 | 6.0.11composer require typo3/cms-core:^6.0.11 |
Affected Products
typo3typo3Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms-core to 4.5.31 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-7078 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2013-7078 in your dependencies?
Find it across Packagist, including transitive dependencies.