CVE-2013-7077 — cms-core
CVE-2013-7077 is a Cross-site Scripting (XSS) vulnerability in typo3/cms-core. A fix is available for typo3/cms-core — see the affected versions and patch details below.
TYPO3 Cross-site scripting (XSS) vulnerability in the Backend User Administration Module
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
typo3/cms-core🐘typo3/cms-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting (XSS) vulnerability in the Backend User Administration Module in TYPO3 6.0.x before 6.0.12 and 6.1.x before 6.1.7 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms-core | ≥ 6.0&&< 6.0.12 | 6.0.12composer require typo3/cms-core:^6.0.12 |
| 🐘Packagist | typo3/cms-core | ≥ 6.1&&< 6.1.7 | 6.1.7composer require typo3/cms-core:^6.1.7 |
Affected Products
typo3typo3Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms-core to 6.0.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-7077 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2013-7077 in your dependencies?
Find it across Packagist, including transitive dependencies.