CVE-2013-6480 — apache-libcloud
Fix: apache/libcloud@4449e16CVE-2013-6480 is a Information Exposure vulnerability in apache-libcloud. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for apache-libcloud — see the affected versions and patch details below.
Libcloud does not properly scrub data when destroying a DigitalOcean node
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
apache-libcloudReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Libcloud 0.12.3 through 0.13.2 does not set the scrub_data parameter for the destroy DigitalOcean API, which allows local users to obtain sensitive information by leveraging a new VM.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | apache-libcloud | ≥ 0.12.3&&< 0.13.3 | 0.13.3pip install --upgrade 'apache-libcloud==0.13.3' |
Affected Products
libcloudapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Apache Libcloud Digital Ocean API - Local Information Disclosure
by anonymous · Jan 1, 2014
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for apache-libcloud, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update apache-libcloud to 0.13.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-6480 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is CVE-2013-6480 in your dependencies?
Find it across PyPI, including transitive dependencies.