CVE-2013-6461 — nokogiri
MEDIUMCVE-2013-6461 is a medium-severity (CVSS 6.5) CWE-776 vulnerability in nokogiri. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for nokogiri — see the affected versions and patch details below.
Nokogiri vulnerable to DoS while parsing XML entities
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
nokogiri💎nokogiriReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Nokogiri gem 1.5.x and 1.6.x has DoS while parsing XML entities by failing to apply limits
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | nokogiri | ≥ 1.5.0&&< 1.5.11 | 1.5.11bundle update nokogiri --conservative |
| 💎RubyGems | nokogiri | ≥ 1.6.0&&< 1.6.1 | 1.6.1bundle update nokogiri --conservative |
Affected Products
debian linuxdebiannokogirinokogiricloudforms management engineredhatenterprise mrgredhatopenstackredhatsatelliteredhatResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nokogiri, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update nokogiri to 1.5.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-6461 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2013-6461 in your dependencies?
Find it across RubyGems, including transitive dependencies.