NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2013-6418 — pywbem

HIGHFix: pywbem/pywbem@f759937

CVE-2013-6418 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in pywbem. A fix is available for pywbem — see the affected versions and patch details below.

PyWBEM TOCTOU vulnerability in certificate validation

Also known asPYSEC-2014-93
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk-0.01%
Lower risk than most CVEs77th percentile — riskier than 77% of all scored CVEsHighest risk
0.00%0.76%1.52%2.29%0.3%1.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍pywbem

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

PyWBEM 0.7 and earlier uses a separate connection to validate X.509 certificates, which allows man-in-the-middle attackers to spoof a peer via an arbitrary certificate.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIpywbemall versions0.8.1pip install --upgrade 'pywbem==0.8.1'

Affected Products

1 product · 1 configurations
Application
pywbempywbem_project
≤ 0.7
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pywbem, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update pywbem to 0.8.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-6418 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

PyWBEM 0.7 and earlier uses a separate connection to validate X.509 certificates, which allows man-in-the-middle attackers to spoof a peer via an arbitrary certificate.
O3 Security · Impact-Aware SCA

Is CVE-2013-6418 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2013-6418: pywbem — Fixed in 0.8.1