NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2013-6407 — solr-core

Fix: apache/lucene-solr@f230486

CVE-2013-6407 is a security vulnerability in org.apache.solr:solr-core. EPSS puts its 30-day exploitation probability at 11.4% (96th percentile). A fix is available for org.apache.solr:solr-core — see the affected versions and patch details below.

Apache Solr UpdateRequestHandler for XML resolves XML External Entities

Also known asGHSA-998j-j6v9-5846
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
11.4%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs96th percentile — riskier than 96% of all scored CVEsHighest risk
10.9%11.2%11.6%11.9%11.4%11.4%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
☕org.apache.solr:solr-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The UpdateRequestHandler for XML in Apache Solr before 4.1 allows remote attackers to have an unspecified impact via XML data containing an external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.solr:solr-coreall versions4.1.0org.apache.solr:solr-core:4.1.0

Affected Products

1 product · 6 configurations
Application
solrapache
≤ 4.0.0
4 versions
3.6.03.6.13.6.24.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.solr:solr-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.solr:solr-core to 4.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-6407 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat JBoss Data Grid 6.2solrRHSA-2014:0029
Red Hat JBoss Web Framework Kit 2.4solrRHSA-2013:1844

Frequently Asked Questions

The UpdateRequestHandler for XML in Apache Solr before 4.1 allows remote attackers to have an unspecified impact via XML data containing an external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.
O3 Security · Impact-Aware SCA

Is CVE-2013-6407 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2013-6407: solr-core XXE — Fixed in 4.1.0