CVE-2013-6396 is a critical-severity (CVSS 9.1) CWE-310 vulnerability in python-swiftclient. A fix is available for python-swiftclient — see the affected versions and patch details below.
Python Swift client is vulnerable to Missing SSL Certificate Check
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
python-swiftclientReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
The OpenStack Python client library for Swift (python-swiftclient) from 1.0 before 2.0 does not verify X.509 certificates from SSL servers, which allows man-in-the-middle attackers to spoof servers and obtain sensitive information via a crafted certificate.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | python-swiftclient | ≥ 1.0&&< 2.0 | 2.0pip install --upgrade 'python-swiftclient==2.0' |
Affected Products
swiftopenstackDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for python-swiftclient, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update python-swiftclient to 2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-6396 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2013-6396 in your dependencies?
Find it across PyPI, including transitive dependencies.