CVE-2013-5855 — javax.faces
CVE-2013-5855 is a Cross-site Scripting (XSS) vulnerability in org.glassfish:javax.faces. A fix is available for org.glassfish:javax.faces — see the affected versions and patch details below.
Improper Neutralization of Input During Web Page Generation in Mojarra
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.glassfish:javax.faces☕org.glassfish:javax.facesReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Oracle Mojarra 2.2.x before 2.2.6 and 2.1.x before 2.1.28 does not perform appropriate encoding when a (1) <h:outputText> tag or (2) EL expression is used after a scriptor style block, which allows remote attackers to conduct cross-site scripting (XSS) attacks via application-specific vectors.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.glassfish:javax.faces | ≥ 2.2.0&&< 2.2.6 | 2.2.6org.glassfish:javax.faces:2.2.6 |
| ☕Maven | org.glassfish:javax.faces | ≥ 2.1.0&&< 2.1.28 | 2.1.28org.glassfish:javax.faces:2.1.28 |
Affected Products
mojarraoracleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.glassfish:javax.faces, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.glassfish:javax.faces to 2.2.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-5855 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat JBoss BPMS 6.0 | see advisory | RHSA-2015:0234 |
| Red Hat JBoss BRMS 6.0 | see advisory | RHSA-2015:0235 |
| Red Hat JBoss Data Virtualization 6.0 | see advisory | RHSA-2015:0765 |
| Red Hat JBoss Data Virtualization 6.1 | see advisory | RHSA-2015:0675 |
| Red Hat JBoss Fuse Service Works 6.0 | see advisory | RHSA-2015:0720 |
| Red Hat JBoss Operations Network 3.2 | see advisory | RHSA-2014:0910 |
| Red Hat JBoss Portal 6.2 | JSF | RHSA-2015:1009 |
| Red Hat JBoss Web Framework Kit 2.6 | JSF | RHSA-2014:0896 |
Frequently Asked Questions
Is CVE-2013-5855 in your dependencies?
Find it across Maven, including transitive dependencies.