NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm🐘 Packagist
Not in CISA KEV

CVE-2013-4942 — yui

CVE-2013-4942 is a Cross-site Scripting (XSS) vulnerability in yui. A fix is available for yui — see the affected versions and patch details below.

YUI Cross-site Scripting (XSS) vulnerability

Published
Updated
Affected
5 pkgs
Patched
4 / 5
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs68th percentile — riskier than 68% of all scored CVEsHighest risk
0.00%0.56%1.12%1.69%0.3%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

5 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

53other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
yuinpm
31Kdownloads / week

Description

Cross-site scripting (XSS) vulnerability in flashuploader.swf in the Uploader component in Yahoo! YUI 3.5.0 through 3.9.1, as used in Moodle through 2.1.10, 2.2.x before 2.2.11, 2.3.x before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.1, and other products, allows remote attackers to inject arbitrary web script or HTML via a crafted string in a URL.

Affected Packages

5 total 4 fixed
EcosystemPackageVulnerable rangeFix
📦npmyui≥ 3.2.0No fix
🐘Packagistmoodle/moodleall versions2.2.11composer require moodle/moodle:^2.2.11
🐘Packagistmoodle/moodle≥ 2.3.0&&< 2.3.82.3.8composer require moodle/moodle:^2.3.8
🐘Packagistmoodle/moodle≥ 2.4.0-rc1&&< 2.4.52.4.5composer require moodle/moodle:^2.4.5
🐘Packagistmoodle/moodle≥ 2.5.0-beta&&< 2.5.12.5.1composer require moodle/moodle:^2.5.1

Affected Products

2 products · 50 configurations
Application
moodlemoodle
36 versions
2.1.02.1.12.1.22.1.32.1.42.1.52.1.62.1.72.1.82.1.92.1.102.2.0
Application
yuiyahoo
14 versions
3.5.03.5.13.6.03.7.03.7.13.7.23.7.33.8.03.8.13.9.03.9.13.10.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for yui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2013-4942; check the affected-versions list above or the advisory for the patched release of yui, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in flashuploader.swf in the Uploader component in Yahoo! YUI 3.5.0 through 3.9.1, as used in Moodle through 2.1.10, 2.2.x before 2.2.11, 2.3.x before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.1, and other products, allows remote attackers to inject arbitrary web script or HTML via a crafted string in a URL.
O3 Security · Impact-Aware SCA

Is CVE-2013-4942 in your dependencies?

Find it across npm, Packagist, including transitive dependencies.

CVE-2013-4942: yui XSS — Fixed in 2.2.11