NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2013-4662 — civicrm-core

CVE-2013-4662 is a SQL Injection vulnerability in civicrm/civicrm-core. A fix is available for civicrm/civicrm-core — see the affected versions and patch details below.

CiviCRM SQL injection vulnerability via Quick Search API

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs63th percentile — riskier than 63% of all scored CVEsHighest risk
0.00%0.51%1.01%1.52%0.1%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
🐘civicrm/civicrm-core🐘civicrm/civicrm-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The Quick Search API in CiviCRM 4.2.0 through 4.2.9 and 4.3.0 through 4.3.3 allows remote authenticated users to bypass the validation layer and conduct SQL injection attacks via a direct request to the "second layer" of the API, related to contact.getquick.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistcivicrm/civicrm-core≥ 4.2.0&&< 4.2.94.2.9composer require civicrm/civicrm-core:^4.2.9
🐘Packagistcivicrm/civicrm-core≥ 4.3.0&&< 4.3.34.3.3composer require civicrm/civicrm-core:^4.3.3

Affected Products

1 product · 13 configurations
Application
civicrmcivicrm
13 versions
4.2.04.2.14.2.24.2.44.2.54.2.64.2.74.2.84.2.94.3.04.3.14.3.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for civicrm/civicrm-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update civicrm/civicrm-core to 4.2.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-4662 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

The Quick Search API in CiviCRM 4.2.0 through 4.2.9 and 4.3.0 through 4.3.3 allows remote authenticated users to bypass the validation layer and conduct SQL injection attacks via a direct request to the "second layer" of the API, related to contact.getquick.
O3 Security · Impact-Aware SCA

Is CVE-2013-4662 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2013-4662: civicrm-core SQL Injection — Fixed in 4.2.9