NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎 RubyGems
Not in CISA KEV

CVE-2013-4479 — sup

Fix: sup-heliotrope/sup@ca0302e

CVE-2013-4479 is a Code Injection vulnerability in sup. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for sup — see the affected versions and patch details below.

Sup Code Injection vulnerability

Also known asGHSA-hh2x-7mf9-78fr
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs88th percentile — riskier than 88% of all scored CVEsHighest risk
0.00%1.35%2.71%4.06%0.5%3.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
💎sup💎sup

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

lib/sup/message_chunks.rb in Sup before 0.13.2.1 and 0.14.x before 0.14.1.1 allows remote attackers to execute arbitrary commands via shell metacharacters in the content_type of an email attachment.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemssupall versions0.13.2.1bundle update sup --conservative
💎RubyGemssup≥ 0.14.0&&< 0.14.1.10.14.1.1bundle update sup --conservative

Affected Products

1 product · 5 configurations
Application
supsupmua
≤ 0.13.2
4 versions
0.13.00.13.10.14.00.14.1
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for sup, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update sup to 0.13.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-4479 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

lib/sup/message_chunks.rb in Sup before 0.13.2.1 and 0.14.x before 0.14.1.1 allows remote attackers to execute arbitrary commands via shell metacharacters in the content_type of an email attachment.
O3 Security · Impact-Aware SCA

Is CVE-2013-4479 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2013-4479: sup — Fixed in 0.13.2.1